Wide Angle Software Customer Support

   

TouchCopy 09 for Mac will not start.

4 (2 Votes)4 (2 Votes)4 (2 Votes)4 (2 Votes)4 (2 Votes) Average: 4 (2 Votes).

If you are using Mac OSX 10.7 or 10.8, we highly recommend that you upgrade your software to TouchCopy 16.

If you're using OSX 10.6 and TouchCopy 09 Mac does not run when you double click the TouchCopy icon, you may need to upgrade the version of Java installed on your Mac.

Also please ensure you have at least version 9.99 of TouchCopy for Mac installed.

You can download the latest version of TouchCopy 09 for Mac from here.

Publisher: Wide Angle Software
Back to TouchCopy Support
Name: Email:
Message:
As a security check, please complete the reCAPTCHA below:
*Your email address will not be displayed or shared. Please do not include personal information or purchase information such as your activation code or the email address used to purchase. For added security, comments may need to be validated by our support team before they are displayed.

Latest Comments

Herb Sheakley wrote...
2016-01-29
I bought an 09 version of Touchcopy and the MAC it was on died. I had saved my product key and downloaded it on my new mac and it says touchcopy download is damaged move to trash. so pretty much it won't open on my mac. is there anyway for me to get a version that will open or do I need to buy it again?
Wide Angle Software logo
Wide Angle Software wrote...
2016-02-02
@Herb Sheakley Please contact our helpdesk with this so they may provide assistance. It may be that you need to purchase TouchCopy 12 but please run this past our Helpdesk before purchasing it.
Joseph Sena wrote...
2015-12-04
touch copy 09 version is not working for iMac Yosemite 10.10 5 , have a phone 3gs want to transfer photo to my i mac , need a upgrade discount code for touch copy 12
Wide Angle Software logo
Wide Angle Software wrote...
2015-12-07
@Joseph Sena Please contact our helpdesk with this matter and they will be able to provide assistance to www.wideanglesoftware.com/helpdesk
James Barclay wrote...
2014-10-21
Touchcopy 09 refused to work on MacBook now. Do you have an update for 09 version or wil I have to purchase the software again? Im not keen on paying twice for the same software.
Kindest regards
Jamie Barclay
Wide Angle Software logo
Wide Angle Software wrote...
2014-10-22
@James Barclay TouchCopy 09 will may have compatibility issues Mac OS X 10.7 or later. It is therefore recommended that you upgrade to TouchCopy 12 if your MacBook is running a later version of Mac OS X. I am sorry for any inconvenience that this may cause.